Daftar Perintah/Command pada Router Cisco



Saya hanya sekedar ingin sharing saja, untuk menambah pengetahuan kita terhadap dunia IT terutama di bidang setting-menyetting khususnya bagi anda yang masih merasa “NEWBIE” atau pemula. Kali ini saya akan menjelaskan Daftar Perintah/Command pada Router Cisco. Tapi bagi anda yang sudah merasa “PRO” atau mahir, terserah anda jika tetap ingin melanjutkan membaca atau tidak, saya tidak akan memaksa.

☺Usermode Commands

   1. disconnect,memutus sesi telnet dan logout
   2. enable, masuk ke privilegemode
   3. ping
   4. traceroute

☺Privilegemode Commands

   1. clear arp-cache, hapus cache arp
   2. configure terminal, masuk ke global configuration mode
   3.copy running-config startup-config, menyimpan konfigurasi yang sedang berjalan
   4. copy startup-config running-config, load konfigurasi yang  tersimpan
   5. debug ip packet, debug paket dari tcp/ip
   6. disable, kembali ke privilegemode dari global configuration mode
   7. disconnect , memutus hubungan telnet
   8. erase startup-config, hapus file konfigurasi dari router
   9. logout, keluar dari privilegemode
  10. ping , mengecek koneksi antar devices
  11. reload, load kembali startup-config
  12. resume , menyambung kembali setelah diputus
  13. show access-list, memerlihatkan semua access-list dari semua
protokol pada  router
  14. show banner, memerlihatkan banner
  15. show cdp, memerlihatkan status CDP router

  16. show cdp interface, memerlihatkan interface CDP
  17. show cdp neighbor
  18. show cdp traffic
  19. show clock , memerlihatkan waktu yang sedang berjalan
  20. show flash, memerlihatkan IOS image dan file yang tersimpan di flash
memory
  21. show frame-relay lmi, memerlihatkan statistik detail LMI
  22. show frame-relay map
  23. show frame-relay pvc
  24. show history, memerlihatkan semua perintah yang telah dieksekusi
  25. show hosts, memerlihatkan static host yang disimpan
  26. show interfaces, memerlihatkan interface yang dimiliki (semua)
secara detail
  27. show interfaces ethernet 0
  28. show interfaces serial 0 ,
  29. show interfaces loopback 0
  30. show ip arp
  31. show ip eigrp neighbors
  32. show ip eigrp neighbors detail
  33. show ip eigrp topology
  34. show ip eigrp traffic, memerlihatkan traffic statistik dari  protokol eigrp
  35. show ip interface
  36. show ip interface brief, verify konfigurasi ip secara singkat
  37. show ip ospf database , memerlihatkan database ip ospf
  38. show ip ospf interface
  39. show ip ospf neighbor detail
  40. show ip route, memperlihatkan konfigurasi routing
  41. show protocols, memperlihatkan protokol routing yang telah dikonfigurasi dan
sedang berjalan
  42. show running-config, memperlihatkan konfigurasi global yang  sedang berjalan
  43. show sessions, memperlihatkan sesi yang ada sekarang
  44. show startup-config, memperlihatkan konfigurasi yang tersimpan  pada flash
  45. show version, memperlihatkan informasi hardware dan firmware
  46. telnet
  47. traceroute
  48. vlan database, mengakses vlan database atau masuk ke konfigurasi  VTP
  49. write erase ,  menghapus file konfigurasi di NVRAM
  50. write memory
  51. write terminal

☺Global configuration mode Commands

   1. access-list {permit|deny}
   2. access-list {permit|deny}
   3. access-list {permit|deny}
   4. access-list {permit|deny}
   5. banner motd
   6. cdp advertise-v2
   7. cdp holdtime , mengubah nilai holdtime cdp
   8. cdp run
   9. cdp timer , mengubah nilai cdp timer
  10. config-register
  11. dialer-list protocol ip permit
  12. enable password , set password untuk masuk ke
mode privilege
  13. enable secret , set enkripsi untuk password yang  disimpan
  14. end, kembali ke mode privilege
  15. hostname , set nama host
  16. interface ethernet 0, masuk ke subconfiguration interface  ethernet 0
  17. interface fastethernet 0, masuk ke subconfiguration interface  fastethernet 0
  18. interface serial 0, masuk ke subconfiguration interface serial 0
  19. interface vlan , masuk ke subconfiguration vlan
  20. ip default-gateway , set default gateway
  21. ip default-network
  22. ip host , set static hostname lain
  23. ip name-server , set DNS router
  24. ip route {next-hop-ip-addr|interface-type}
  25. ip route 0.0.0.0 0.0.0.0 , set defaut gateway /  static route
  26. ip route , set static route
  27. ip routing
  28. ipx routing
  29. isdn switch-type
  30. line aux
  31. line console 0, masuk ke konfigurasi console nomer 0
  32. line vty 0 4, masuk ke konfigurasi vty untuk 5 buah vty
  33. no banner motd, menghapus banner
  34. no ip routing, menghapus ip routing
  35. no router igrp, menghapus konfigurasi route igrp
  36. no router ospf, menghapus konfigurasi route ospf
  37. no router rip, menghapus konfigurasi route rip
  38. no vlan , menghapus vlan nomer ke sekian
  39. router eigrp , masuk ke konfigurasi routing menggunakan  eigrp
  40. router ospf , masuk ke konfigurasi routing menggunakan  ospf
  41. router rip, masuk ke konfigurasi routing menggunakan rip
  42. snmp-server enable traps vtp
  43. username password , set username dan
passwordnya

☺Interface subconfiguration mode Commands

   1. bandwidth , set bandwidth yang akan dilalui interface
        ini dalam kilobits
   2. cdp enable ,  Mengaktifkan cdp
   3. clock rate , set clock rate dalam bits/s
   4. compress stac in

☺Line subconfiguration mode Commands

   1. exec-timeout [detik], pilihan detik opsional
   2. logging synchronous
   3. password , memberikan password

☺Subinterface subconfiguration mode Commands

   1. description , set deskripsi dari subinterface

☺IP Routing Protocol subconfiguration mode Commands

   1. network , set ip network

Contoh :
TKJ>enable
TKJ#configure terminal atau conf t
TKJ(router)#interface fast eth0/0 atau int f0/0
TKJ(router-config)#ip add 192.168.1.1 255.255.255.0  (contoh)
TKJ(router-config)#no sh     (mengaktifkan Network IP seperti service
network restart jika di linux)
TKJ(router-config)#end      (Bisa juga dengan menekan tombol CTRL+Z pada keyboard)
TKJ#show ip interface brief        ( melihat configurasi IP yg telah diseting )

☺Perintah yang sering digunakan dalam konfigurasi Router CISCO :

1.  Setting Password
router>enable
router#conf t
router(config)#enable password cisco (set password untuk masuk ke mode privilege)
router(config)#enable secret secret (set enkripsi untuk password yang  disimpan)

2. Setting Host Name
router>enable
router#conf t
router(config)#hostname

3. Setting VLAN
router>enable
router#conf t
router(config)#vlan
router(config-vlan)#name

4. Setting IP Address pada VLAN
router>enable
router#conf t
router(config)#interface vlan 1       (contoh)
router(config-if)#ip add
(misal: ip address 172.10.46.1 255.255.255.0)
router(config-if)#no shutdown

5. Setting Identitas pada Port Cisco Catalyst
router>enable
router#conf t
router(config)#interface nama-port
router(config-if)#description “Port Setting Identitas”   (tanpa tanda kutip)
router(config-if)#end

6. Setting IP Gateway
router>enable
router#conf t
router(config)#ip default-gateway (address)

7. Setting Port-Speed dan Link-Mode
router#conf t
router(config)#interface (misal : interface fast ethernet 0/1)
router(config-if)#speed 100
router(config-if)#duplex full
router#conf t
router(config)#interface
router(config-if)#switchport mode access
router(config-if)#switchport access vlan
router#conf t
router(config)#interface
router(config-if)#switchport mode trunk
router(config-if)#switchport trunk allowed vlan

8. Setting Line VTY
router#conf t
router(config)#line vty 0 4
router(config-line)#login
router(config-line)#password

9. Setting Line Con 0
router#conf t
router(config)#line con 0
router(config-line)#login
router(config-line)#password

10. Melihat Semua Konfigurasi
router#show running-config

11. Menghapus Semua Konfigurasi
router#erase startup-config
router#dir
router#delete flash:vlan.dat
router#dir
router#reload


    * Usermode Commands

1.# disconnect //hapus sesi telnet dan logout
2.# enable //masuk ke privilegemode
3.# ping //Test Koneksi Jaringan
4.# traceroute //Trace IP

    * Privilegemode Commands

1. # clear arp-cache //hapus cache arp
2. #configure terminal // masuk ke global configuration mode
3. #copy running-config startup-config // simpan konfigurasi sekarang
4.# copy startup-config running-config//load konfigurasi yang tersimpan
5. #debug ip packet//debug paket dari tcp/ip
6. #disable// kembali ke privilegemode dari global configuration mode
7. #disconnect
8. #erase startup-config//hapus file konfigurasi dari router
9. #logout,//keluar dari privilegemode
10. #ping
11. #reload// load kembali startup-config
12.# resume //konek kembali setelah diskonek
13.# show access-list //memperlihatkan semua access-list dari semua protokol pada router
14. #show banner // memperlihatkan banner
15. #show cdp //memperlihatkan status CDP router
16. #show cdp interface //memperlihatkan interface CDP
17.# show cdp neighbor
18. #show cdp traffic
19. #show clock
20. #show flash // memperlihatkan IOS image dan file yang tersimpan di flash memory
21.# show frame-relay lmi // memperlihatkan statistik detail LMI
22. #show frame-relay map
23.# show frame-relay pvc
24.# show history //memperlihatkan semua perintah yang telah dieksekusi
25. #show hosts //memperlihatkan static host yang disimpan
26. #show interfaces // memperlihatkan interface yang dimiliki (semua) secara detail
27.# show interfaces ethernet 0
28.# show interfaces serial 0
29. #show interfaces loopback 0
30.# show ip arp
31. #show ip eigrp neighbors
32. #show ip eigrp neighbors detail
33.# show ip eigrp topology
34.# show ip eigrp traffic // memperlihatkan traffic statistik dari protokol eigrp
35. #show ip interface , Melihat ip dari interface
36. #show ip interface brief //verify konfigurasi ip
37. #show ip ospf database
38. #show ip ospf interface
39. #show ip ospf neighbor detail
40. #show ip route // memperlihatkan konfigurasi routing
41. #show protocols //memperlihatkan protokol routing yang telah dikonfigurasi dan sedang berjalan
42. #show running-config //memperlihatkan konfigurasi global yang sedang berjalan
43. #show sessions // memperlihatkan sesi yang ada sekarang
44. #show startup-config // memperlihatkan konfigurasi yang tersimpan pada flash
45. #show version // memperlihatkan informasi hardware dan firmware
46.# telnet
47. #traceroute
48. #vlan database // mengakses vlan database atau masuk ke konfigurasi VTP
49. #write erase
50. #write memory
51. #write terminal

    * Global configuration mode Commands

1. #access-list {permit|deny}
2. #access-list {permit|deny}
3. #access-list {permit|deny}
4. #access-list {permit|deny}
5. #banner motd
6. #cdp advertise-v2
7. #cdp holdtime // mengubah nilai holdtime cdp
8. #cdp run
9. #cdp timer // mengubah nilai cdp timer
10.# config-register
11. #dialer-list protocol ip permit
12. #enable password //set password untuk masuk ke mode privilege
13. #enable secret // set enkripsi untuk password yang disimpan
14. #end // kembali ke mode privilege
15. #hostname // set nama host
16. #interface ethernet 0 // masuk ke subconfiguration interface ethernet 0
17. #interface fastethernet 0 // masuk ke subconfiguration interface fastethernet 0
18. #interface serial 0 //masuk ke subconfiguration interface serial 0
19. #interface vlan // masuk ke subconfiguration vlan
20. #ip default-gateway // set default gateway
21. #ip default-network
22. #ip host // set static hostname lain
23. #ip name-server //set DNS router
24. #ip route {next-hop-ip-addr|interface-type}
25. #ip route 0.0.0.0 0.0.0.0 , //set defaut gateway / static route
26. #ip route // set static route
27. #ip routing
28. #ipx routing
29. #isdn switch-type
30. #line aux
31. #line console 0 //masuk ke konfigurasi console nomer 0
32. #line vty 0 4 // masuk ke konfigurasi vty untuk 5 buah vty
33. #no banner motd //menghapus banner
34. #no ip routing // menghapus ip routing
35. #no router igrp //menghapus konfigurasi route igrp
36. #no router ospf // menghapus konfigurasi route ospf
37. #no router rip // menghapus konfigurasi route rip
38. #no vlan // menghapus vlan nomer ke sekian
39. #router eigrp // masuk ke konfigurasi routing menggunakan eigrp
40.# router ospf // masuk ke konfigurasi routing menggunakan ospf
41. #router rip // masuk ke konfigurasi routing menggunakan rip
42. #snmp-server enable traps vtp
43.#username password // set username dan passwordnya

    * Interface subconfiguration mode Commands

1. #bandwidth // set bandwidth yang akan dilalui interface ini dalam kilobits
2.# cdp enable
3. #clock rate // set clock rate dalam bits/s
4. #compress stac in

    * Line subconfiguration mode Commands

1. #exec-timeout [detik] // pilihan detik opsional
2. #login synchronous
3. #password //set passwordnya

    * Subinterface subconfiguration mode Commands

1. #description // set deskripsi dari subinterface

    * IP Routing Protocol subconfiguration mode Commands

1. #network // set ip network
These icons link to social bookmarking sites where readers can share and discover new web pages.
  • Digg
  • Sphinn
  • del.icio.us
  • Facebook
  • Mixx
  • Google
  • Furl
  • Reddit
  • Spurl
  • StumbleUpon
  • Technorati
Reaksi: